В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maevava
maevava
02.06.2021 03:37 •  Информатика

Дано натуральное число n,последовательность целых чисел a1,.составить программу ,которая последовательно прибавляя членв последовательности, выводит результат,когда сумма впервые превышает число n. если сумма всех членов последовательности не превышает число n, выведите об этом сообщение

Ответ:
илона2707
илона2707
24.04.2020 03:48
Const
  n = 5;
 
var
  arr: array [1..n] of integer;
  i, N1, sum: integer;

begin
  write('N = ');
  readln(N1);
  for i := 1 to n do
  begin
    write('A[', i, '] = ');
    readln(arr[i]);
  end;
 
  i := 1;
  sum := 0;
  while (sum <= N1) and (i <= n) do
  begin
    sum := sum + arr[i];
    i := i + 1;
  end;
 
  if sum > N1 then
    writeln(sum)
  else
    writeln('Summa not grether then N');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?