В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
7846854542
7846854542
20.04.2023 15:04 •  Информатика

Напишите программы в паскале: 1) цикл с предусловием. написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием. написать программу, в которой требуется вводить с клавиатуры числа и подсчитывать их сумму, до первого введенного отрицательного числа; 3) цикл параметром. написать программу, которая находит сумму чисел от 1 до 20

Ответ:
aleksandrafrolo1
aleksandrafrolo1
26.08.2020 07:05
Program n1;
var y, x: integer;
begin
x:=0;
while x<10 do begin
x:=x+2;
y:=x*x;
writeln(y);
end;
end.

Program n2;
var x, sum: real;
begin
sum:=0;
repeat
readln(x);
if(x>=0) then sum:=sum+x;
until x<0;
writeln(sum);
end.

Program n3;
var a, i: integer;
begin
a:=0;
for i:=1 to 20 do a:=a+i;
writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?