В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ksimonova196
ksimonova196
08.01.2022 04:33 •  Информатика

Pascal составить программу поиска трех значных чисел, сумма цифр которого равна n

Ответ:
tanyucsgha
tanyucsgha
08.09.2020 19:57
Var
  i, n, s, k: integer;
begin
  readln(n);
  for i := 100 to 999 do
  begin
     s := 0; k := i;
     while  k > 0 do
     begin
        s := s + k mod 10;
        k := k div 10;
     end;
     if s = n then
        writeln(i);
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?