В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ulpashkova
ulpashkova
29.10.2020 05:19 •  Информатика

Дан вектор имеющий n (1< =n< =100)целых элементов. напишите программу которая находит среднее арифметическое значение элементов, стоящих на нечётных позициях

Ответ:
socnyjarbuz
socnyjarbuz
24.04.2020 00:53
#include <iostream>
#include <vector>
using namespace std;

int main() {
    unsigned short int n;
    cout << "n = ";
    cin >> n;
    vector<int> a;
    int in,
        avg,
        s = 0,
        c = 0;
    for (int i = 0; i < n; ++i) {
        cout << "a[" << i << "] = ";
        cin >> in;
        a.insert(a.end(), in);
        if (i % 2 == 1) {
            s += a.back();
            c++;
        }
    }
    avg = (int) s / c;
    cout << "Среднее арифметическое элементов на нечётных позициях: "
         << avg;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?