В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
ниёля1
ниёля1
18.11.2021 17:37 •  Информатика

Напишите программу которая удаляет из заданного текста комбинацию "ем" (земля-планета солнечной системы)

Ответ:
TOMIRIBOT
TOMIRIBOT
05.10.2020 04:24
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('ем',''); s.Println
end.

Пример
> земля- планета солнечной системы
зля- планета солнечной систы
0,0(0 оценок)
Ответ:
Nejdan1
Nejdan1
05.10.2020 04:24
// PascalABC.NET (версия 3.2, сборка 1363)

const
  RM = 'ем';
var
  c, n: char;
  seq: boolean := False;
  s: string := 'Земля - планета солнечной системы';
begin
  writeln(s);
  for var i := 1 to (length(s) -1) do
  begin
    c := s[i];
    n := s[i+1];
    if seq = True then
    begin
      seq := False;
      continue;
    end;
    if (c = RM[1]) and (n = RM[2]) then
    begin
      seq := True;
      continue;
    end
    else
    begin
      seq := False;
      write(c);
    end;
  end;
  write(s[length(s)]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?