В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bogdanka1503p08ifa
bogdanka1503p08ifa
04.08.2021 19:26 •  Информатика

Написать программу в паскаль n-целое число < 1000 испльзуя div и mod определить сколько цифр в этом числе вычислить сумму цифр числа определить чётное оно или нет вывести на экран это же число в обратном порядке

Ответ:
olgaivanova04
olgaivanova04
05.10.2020 04:05
Var a,c,n2,n,sum,col:integer;
begin
readln(n);
n2:=n;
a:=0;
sum:=0;
col:=0;
if n<1000 then begin
while(n2>0) do begin
  c:=n2 mod 10;
  n2:=n2 div 10;
  a:=(c+a)*10;
  sum:=sum+c;
col:=col+1;
end;
writeln(col);
writeln(sum);
if (n mod 2 =0) then writeln('чётное')
else writeln('нечётное');
writeln(a div 10);
end
else write(n' больше 1000!');
end.
0,0(0 оценок)
Ответ:
Disengaliev
Disengaliev
05.10.2020 04:05
Program pos;
var
    n, a, b, c, s, d: integer;
begin
    write('n = ');
    readln(n);
    if n < 1000 then
    begin
        a := n div 100;
        b := n mod 100 div 10;
        c := n mod 10;
        write('В числе ');
        if a = 0 then
            if b = 0 then
            begin
                d := 1;
                writeln('1 цифра');
            end
            else
            begin
                d := 2;
                writeln('2 цифры');
            end
        else
        begin
            d := 3;
            writeln('3 цифры');
        end;
        s := a + b + c;
        writeln('Сумма цифр: ', s);
        if n mod 2 = 0 then
            writeln('Число чётное')
        else
            writeln('Число нечётное');
        if d = 1 then
            writeln(c)
        else
            if d = 2 then
                writeln(c, b)
            else
                writeln(c, b, a);
        end
    else
        writeln('Число > 1000!');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?