В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на pascal, используя рекурсию: дан набор символов, оканчивающихся пробелом (короче это слово), вывести символы в обратном порядке, используя рекурсию.

Ответ:
аниметян3
аниметян3
05.10.2020 04:02
Var s: string;
procedure PrintChar(s:string;n:integer);
begin
    if s[n]<>' '
     then begin PrintChar(s,n+1); write(s[n]); end;
end;
begin
    write('Введите слово: ');
    readln(s);
    PrintChar(s,1);
end.

Пример:
Введите слово: телефон 
нофелет
0,0(0 оценок)
Ответ:
SakuraHarunoo
SakuraHarunoo
05.10.2020 04:02
Program pos;
var
    s: string;
    l: integer;
procedure PrintChar(n: integer);
var
    sub: string;
begin
    sub := Copy(s, n, 1);
    write(sub);
    if n <> 1 then
        PrintChar(n - 1);
end;
begin
    write('Введите слово: ');
    readln(s);
    l := Length(s);
    PrintChar(l);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?