В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
садов19
садов19
15.05.2023 12:29 •  Информатика

Напишите на паскале. : написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом r

Ответ:
iuliazhdanovaЮлька
iuliazhdanovaЮлька
05.10.2020 03:13
Var a,b,c,r,s,p: real;
begin
  write('длины сторон треугольника a,b,c через пробел: ');
  readln(a,b,c);
  write('радиус круга r: ');  readln(r);
  p:=(a+b+c)/2;
  s:=sqrt(p*(p-a)*(p-b)*(p-c));
  if r>=(a*b*c)/(4*s) then writeln('можно поместить')
  else writeln('нельзя поместить');
end.

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.49
нельзя поместить

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.5
можно поместить
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?