В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Duhan1
Duhan1
12.03.2023 20:43 •  Информатика

Написать программу, в результате работы которой будут заполнятся и выводится в строчку на экран целочисленный массив c из 7 элементов. значения элементов массива находятся в диапазоне от −10 до 10 и заполняются случайным образом. выполнить: поиск наибольшего сортиовать по возрастанию

Ответ:
Svetlanalitv
Svetlanalitv
08.09.2020 19:17
#include <iostream>
#include <algorithm>
#include <ctime>
using namespace std;
const int ARRAY_SIZE = 7;
int c[ARRAY_SIZE];

void print_array();

int main(int argc, char *argv[])
{
    srand ( time(NULL)  );
    cout << "---   ЗАПОЛНЕНИЕ МАССИВА  ---\n";
    for (int i = 0; i < ARRAY_SIZE; ++i) {
        c[i] = rand() % 21 - 10;
        cout << c[i] << ' ';
    }
    cout << "\n---    МАССИВ ЗАПОЛНЕН    ---\n";
    cout << "---   ПОИСК НАИБОЛЬШЕГО   ---\n";
    int max = c[0];
    for (int i = 0; i < ARRAY_SIZE; ++i) {
        if (c[i] > max) max = c[i];
    }
    cout << "---    ПОИСК ЗАВЕРШЁН     ---\n"
         << "Наибольшее: " <<   max   << '\n'
         << "---   НАЧАЛО СОРТИРОВКИ   ---\n";
    sort(c, c + ARRAY_SIZE);
    cout << "---  МАССИВ ОТСОРТИРОВАН  ---\n";
    print_array();
    return 0;
}

void print_array() {
    cout << "---     ВЫВОД НА ЭКРАН    ---\n";
    for (int i = 0; i < ARRAY_SIZE; ++i) {
        cout << c[i] << ' ';
    }
    cout << "\n---      КОНЕЦ ВЫВОДА     ---\n";
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?