В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lЕвгешкаl
lЕвгешкаl
21.08.2020 18:03 •  Информатика

Напишите программу ( в паскале авс), которая вычисляет число пи с заданной пользователем точностью. воспользуйтесь данными и условием предыдущей . (условие предыдущей : напишите программу, которая вычисляет частичную сумму ряда 1-1/3+1/5-1/7+1/ и сравнивает полученное значение с пи/4).

Ответ:
mikkie3
mikkie3
05.10.2020 02:56
Var s,sgn,eps: real;
    i: integer;
begin
  write('точность вычислений: ');
  readln(eps);
  s:=1;  sgn:= -1;
  i:=3;
  repeat
    s:=s+sgn/ i;
    sgn:= - sgn;
    i:=i+2;
  until 8/i<eps;
  writeln('число пи:  ',s*4);
  writeln('точное значение пи: ',pi);
end.    

точность вычислений: 1.0e-6
число пи:  3.14159240358966
точное значение пи: 3.14159265358979
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?