Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
artem28
23.01.2021 16:24 •
Информатика
Сделайте программу в паскале. вводится любое количество чисел определяемое пользователем и надо из этих чисел вывести наименьшии числа
Ответ:
zaxarenko2018
05.10.2020 02:38
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Укажите количество чисел:');
var a:=ReadArrReal('Вводите: ',n);
var m:=a.Min;
Writeln(a.Where(x->x=m))
end.
Пример
Укажите количество чисел: 6
Вводите: -3 2.4 -7 0 -7 3
[-7,-7]
0,0
(0 оценок)
Популярные вопросы: Информатика
Нина20071
13.08.2021 22:24
Подскажите интересную тему для проекта по информатике...
ZakAnyta
19.05.2020 16:56
Решите тест. Совокупность допустимых операторов языка программирования – это а) семантика языка программирования; б) синтаксис языка программирования; в) программа....
yuldumenko
15.01.2022 04:13
Расстояние между городами 300км Преодолеет ли это расстояние за 3 часа автомобиль, движущийся со скоростью V км/ч Ввод Скорость автомобиля : 105 Скорость автомобиля:...
Dimon200315
06.12.2021 08:09
A) MCCCLXXX 3) MCXLVII 4) MDCCIII...
void1231
28.09.2020 14:32
Дан массив a(15). определите сумму элементов массива кратных 7...
26040717
28.09.2020 14:32
Вмассиве хранится информации о стоимости каждой из 60 книг. определить количество самых дешёвых книг....
макс3096
28.09.2020 14:32
Умоляю 1.дана целочисленная квадратная матрица. 1) определить положение всех седловых точек матрицы и их количество (седловая точка – это элемент матрицы, минимальный...
sluvka123123
28.09.2020 14:32
Перечислите заполнения массива...
ник5028
28.09.2020 14:32
Вычислить частное и разность двух чисел...
olgagolikova2
13.12.2022 18:42
Обозначь части тела, которые есть у зверей. 1) шея 2) брюшко 3) ноги 4) плавники...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Укажите количество чисел:');
var a:=ReadArrReal('Вводите: ',n);
var m:=a.Min;
Writeln(a.Where(x->x=m))
end.
Пример
Укажите количество чисел: 6
Вводите: -3 2.4 -7 0 -7 3
[-7,-7]