В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aishaefendieva
aishaefendieva
27.02.2023 05:43 •  Информатика

Впаскале: 1) составить список переменных с указанием типов данных для программы, вычисления среднего роста студентов в группе. 2) составить программу вычисления надбавки к зарплате в зависимости от стажа работы: до 10 лет надбавка равна 10%, далее за каждый год добавляется 2%.

Ответ:
инна1382
инна1382
05.10.2020 02:30
Program q1;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of integer;
countNum:integer; // переменная для хранения количества нечетных чисел
proizv:integer; // переменная для хранения произведения нечетных чисел
BEGIN
proizv:=1; // так как, изначально равно 0, а при умножении на 0 будет всегда 0
{создание последовательности n целых чисел}
Writeln('Случайные целые числа: ');
for i:=1 to n do
begin
mass[ i ]:=random(9)+1; //присваеваем переменной случайное значение от 1 до 10
write(inttostr(mass[ i ])+', ');
end;
{Вычисление произведения и количества нечетных чисел}
for i:=1 to n do
if mass[ i ] mod 2 <> 0 then //проверяем не четное-ли число, если да, то.. .
begin
inc(countNum); //увеличиваем на один кол-во нечетных чисел
proizv:=proizv*mass[ i ]; // высчитываем произведение
end;
{Вывод результатов}
writeln;
writeln('Всего нечетных чисел: '+inttostr(countNum));
writeln('Их произведение: '+inttostr(proizv));
END.


program q2;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of real;
Summ:real; // переменная для хранения суммы чисел
MNum:real; // переменная для хранения среднего арифметического
BEGIN
{создание последовательности n отрицательных вещественных чисел}
Writeln('Случайные отрицательные вещественные числа: ');
for i:=1 to n do
begin
mass[ i ]:=((random(9)+1)+(random(9)+1)/10)*(-1); //присваеваем переменной случайное вещественное от 1 до 10
write(mass[ i ],'; '); //выводим
end;
{Вычисление среднего арифметического}
for i:=1 to n do
Summ:=Summ+mass[ i ]; // высчитываем произведение
MNum:=Summ/n;

{Вывод результатов}
writeln;
writeln('Среднее арифметическое: ',MNum);
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?