В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
qwerty54321
qwerty54321
12.01.2020 06:49 •  Информатика

Написать программу для паскаль! , , ! дано натуральное число. установить, является ли последовательность его цифр, при просмотре их слева направо, по убыванию.

Ответ:
AgentDaleCoop
AgentDaleCoop
05.10.2020 02:21
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin;
  var s:=ReadInteger('n=').ToString;
  If s.Length<>(s.Distinct.Count) then Writeln('не является')
  else
    if s=s.ToCharArray.SortedDescending.JoinIntoString('')
    then Writeln('является') else Writeln('не является')
end.

Примеры
n= 9875431
является

n= 9753321
не является

n= 9763421
не является

Замечание: учтено, что упорядоченность должна быть по убыванию а не по невозрастанию. т.е. нельзя, чтобы попадались две одинаковые цифры.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?