Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
марина1924
08.06.2023 20:53 •
Информатика
Составить алгоритм и написать решение на паскале: сгенерировано целое число в диапазоне от 20 до 30. найти диагональ квадрата с данной стороной.
Ответ:
ismailtagiev20
23.04.2020 18:32
Var a:integer;
x:real;
begin
a:=random(20,30);
x:=sqrt(sqr(a)+sqr(a));
writeln('сторона= ',a);
writeln('диагональ= ',x);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
whitesnaff
20.02.2022 00:46
Автоматическая камера производит растровые изображения размером 512×512 пикселов. при этом объём файла с изображением не может превышать 64 кбайт, упаковка данных не производится....
ксюша1647
29.11.2020 07:38
Пользователь работал с каталогом логика. сначала он поднялся на один уровень вверх, затем он поднялся еще на один уровень вверх, затем спустился на один уровень вниз. в результате...
366023
12.03.2020 23:30
Дописать программу на языке c++. нужно реализовать поиск в тексте символа : и вывод этой строки на экран....
polinaskibina
12.03.2020 23:30
Составьте программу для вычисления площади прямоугольного треугольника по его катетам a и b. на строительных работах нужно отработать s часов, в подразделении n строителей....
divamurmyrlena
24.12.2021 08:51
Exel 2007 составьте таблицу значений функции на отрезке [-3; 3] построить график функции. y=(5-x)/(x^2)+3...
aizhan79
24.12.2021 08:51
Какой минимальный объём памяти (в кбайт) нужно зарезервировать, чтобы можно было сохранить любое растровое изображение размером 512×512 пикселов при условии, что в изображении...
Агент271
24.12.2021 08:51
Автоматическая камера производит растровые изображения размером 2048×1024 пикселов. при этом объём файла с изображением не может превышать 2 мбайт, упаковка данных не производится....
Polina211004
04.10.2022 08:14
Увага! перевод чисел! необходимо перевести число 770 (оно уже находится в 8 системе) из восьмеричной системы счисления в 16-чную, не прибегая к сторонних систем счисления...
Superpuper228911
16.12.2022 09:06
Переведите число x10=94 в двоичную систему...
Duna383292928282
16.12.2022 09:06
Дан вещественный вектор длины n найти min элемент среди положительных компонент массива. нужно написать программу в pascal....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x:real;
begin
a:=random(20,30);
x:=sqrt(sqr(a)+sqr(a));
writeln('сторона= ',a);
writeln('диагональ= ',x);
end.