В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Jelly1727
Jelly1727
21.01.2022 02:56 •  Информатика

Напишите, , программы (паскаль). 1. ввести два целых числа, если первое число больше второго, то посчитать сумму этих чисел, иначе прибавить ко второму числу 10. 2. напишите программу, которая по координатам (номеру столбца и номеру строки) двух клеток шахматной доски определяет, одного они цвета или разного

Ответ:
марленна
марленна
31.08.2020 17:29
1.
var a,b:integer;
begin 
readln(a,b);
if a>b then a:=a+b
else b:=b+10;
print ('a =',a,'b =',b);
end.
2.
var
a,a1,b,b1,x,y:integer;
begin
readln(a,a1,b,b1);
x:=0;
y:=0;
if ((a mod 2=0)and(a1 mod 2=0) or (a mod 2=1) and (a1 mod  2=1)) then
x:=1
else
x:=0;
if ((b mod 2=1)and(b1 mod 2=0) or (b mod 2=0) and (b1 mod  2=1)) then
y:=1
else y:=0;
if x<>y then write('Да') else write ('Нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?