В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
juliina902
juliina902
05.11.2022 23:15 •  Информатика

Начертить блок-схему и составить программу, которая вычислит среднее арифметическое четных(или не четных, без разницы) чисел на интервале от a до b включительно.

Ответ:
SofiaAM
SofiaAM
05.10.2020 01:36
Блок-схема - в прилагаемом файле.
var a,b,s,k,i:integer;
begin
writeln('A, B:');
readln(a,b);
s:=0; k:=0;
for i:=a to b do
 begin
 s:=s+i; k:=k+1;
 end;
writeln('Среднее арифм. четных = ',s/k);
end.

Пример:
A, B:
5 15
Среднее арифм. четных = 10
Начертить блок-схему и составить программу, которая вычислит среднее арифметическое четных(или не че
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?