В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу для паскаля : найдите наименьший элемент квадратной таблицы и замените его нулем

Ответ:
Vovachka1
Vovachka1
23.05.2020 22:55

var
i, j, min, min_i, min_j: integer;
a: array[1..5, 1..5] of integer;

begin
for i := 1 to 5 do
begin
for j := 1 to 5 do
begin
a[i, j] := random(100) + 1;
write(a[i, j]:4);
end;
writeln;
end;
min := 999;
for i := 1 to 5 do
for j := 1 to 5 do
if min > a[i, j] then
begin
min := a[i, j];
min_i := i;
min_j := j;
end;
a[min_i, min_j] := 0;
writeln('Массив с замененным минимальным элементом');
for i := 1 to 5 do
begin
for j := 1 to 5 do
write(a[i, j]:4);
writeln;
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?