В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Write234
Write234
30.09.2021 20:09 •  Информатика

Уровень а. (оценка 3). напишите программу, которая выводит m линий из символа s, заданного пользователем длиной n символов. при запуске программы m, n, s нужно ввести с клавиатуры. пример: количество линий: 2. длина цепочки: 7. символ-заполнитель: - для реализации программы напишите процедуру line, которая принимает два параметра – символ-заполнитель s и натуральное число n, и выводит на экран одну линию из символов s длиной n. пример: длина цепочки: 7. символ-заполнитель: -

Ответ:
Ванесса07
Ванесса07
05.10.2020 01:31
//PascalABC.NET 3.2 сборка 1318

Var
  m,n,i:integer;
  s:char;

procedure line(c:char;n:integer);
Var
  i:integer;
begin
for i:=1 to n do
write(c);
writeln;
end;
 

begin
readln(m,n);
readln(s);
for i:=1 to m do
line(s,n);
end.

Пример ввода:
2
7
-
Пример вывода:
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?