Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
osadtsamax
20.04.2020 16:35 •
Информатика
Нужно написать программу для авс паскаль. программа должна переводить обыкновенные числа в двоичную систему счисления. заранее большое ! 87
Ответ:
Jelinad
05.10.2020 01:30
Var n,m:integer;
s:string;
begin
write('n = ');
readln(n);
m:=n;
s:='';
while m>0 do
begin
if m mod 2=0
then s:='0'+s else s:='1'+s;
m:=m div 2;
end;
writeln(s);
end.
Пример:
n = 115
1110011
0,0
(0 оценок)
Ответ:
Vikohkamy
05.10.2020 01:30
Var
a: integer;
function p(x: integer): string;
var
s: string;
begin
s := '';
while x > 0 do
begin
s := chr(ord('0') + x mod 2) + s;
x := x div 2;
end;
p := s;
end;
begin
readln(a);
writeln(p(a));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Girjd
15.12.2022 17:44
Объясните цикл int n , x , k = 0; cin n; for (int i = 1; i = n ; i++) { cin x; if (x == 0) k++; } cout k;...
Nika5647
09.12.2021 12:55
Дано число n.определите количество делителей этого числа.(без остатка). нужно составить программу. ,буду...
natalyasergeev1
10.08.2020 21:43
Информатика : злая мачеха отправила падчерицу к роднику за водой и сказала : вот тебе 2 ведра,в одно из них входит 9 литров воды а в другое -6 литров но ты должна мне примести...
see99aa
10.08.2020 21:43
Слово: _ _к_ _та_ _тематика: профессии...
nik232451
19.10.2021 01:45
Компьютер выдаёт ошибку : ожидалось имя типа не могу разобратся в чём дело. вот что я сделала : var a,b : integer; writeln: ( vvedite a, b ); readeln(a,b) writeln( a b ); writeln(...
vikapataeva
05.06.2023 20:51
1. для чего служат в html символы / title /head : а) для выделения абзаца б) для выделения параграфа, пункта в) для выделения глав г) для выделения заголовка 2. какие форматы...
AliceMysova
05.06.2023 20:51
Какие страницы называют статическими?...
lilikykytik21
05.06.2023 20:51
Как называется программа где можно сделать буклет? и как делать буклет?...
2kkdKristina
23.02.2022 20:36
Значком /\ обозначена логическая операция и, значком \/ - логическая операция или, значком ¬ - логическая операция не, значком → - логическая операция следования для какого символьного...
Водород56
18.01.2022 08:03
850г+3кг 150г грам есебиментабындар...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
s:string;
begin
write('n = ');
readln(n);
m:=n;
s:='';
while m>0 do
begin
if m mod 2=0
then s:='0'+s else s:='1'+s;
m:=m div 2;
end;
writeln(s);
end.
Пример:
n = 115
1110011
a: integer;
function p(x: integer): string;
var
s: string;
begin
s := '';
while x > 0 do
begin
s := chr(ord('0') + x mod 2) + s;
x := x div 2;
end;
p := s;
end;
begin
readln(a);
writeln(p(a));
end.