В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gio8
gio8
22.06.2022 00:24 •  Информатика

Turbo pascal 1. напишите программу вычисления длин сторон треугольника a,b и c по указанным формулам. величины углов треугольника d ,e , f заданные в градусах, радиус описанной окружности r вводятся с клавиатуры. градусы описанной окружности r вводятся с клавиатуры. градусы d,e,f предварительно переведите в радианы x y z по формуле a=2r sin x , b=2r sin y, c= 2rsin z. 2.для четырех произвольных чисел введенных с клавиатуры, выведите на экран соответствующие результаты. если сумма первого и третьего чисел больше 150, то выведите эту сумму и все четыре числа. , хотя бы с одним , нужно, буду

Ответ:
SecretGuest23
SecretGuest23
05.10.2020 01:28
1)
var a,b,c,d,e,f,r,x,y,z:real;
begin
writeln('d, e, f:');
readln(d,e,f);
write('r = ');
readln(r);
x:=d*pi/180;
y:=e*pi/180;
z:=f*pi/180;
a:=2*r*sin(x);
b:=2*r*sin(y);
c:=2*r*sin(z);
writeln('a = ',a:5:2,' b = ',b:5:2,' c = ',c:5:2);
end.

Пример:
d, e, f:
90 60 30
r = 2.5
a =  5.00 b =  4.33 c =  2.50

2)
var a,b,c,d:integer;
begin
writeln('a, b, c, d:');
readln(a,b,c,d);
if a+c>150
 then writeln('a+c  = ',a+c,' a = ',a,' b = ',b,' c = ',c,' d = ',d);
end.

Пример:
a, b, c, d:
72 18 94 25
a+c  = 166 a = 72 b = 18 c = 94 d = 25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?