В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
darikesa69
darikesa69
09.06.2020 04:55 •  Информатика

Составить программу в паскале abc для решения следующей . с клавиатуры вводятся 3 произвольных числа. если второе число больше суммы первого и третьего , то вывести сумму этих двух чисел.если первое число положительное , то вывести среднее арифметическое трех чисел.

Ответ:
sanay06
sanay06
05.10.2020 01:19
Program qq;
uses CRT;
var x1,x2,x3,sum2,SrArVsChi:integer;
begin
write('Первое число равно ');
readln(x1);
write('Второе число равно ');
readln(x2);
write('Третье число равно ');
readln(x3);
if x2 > (x1+x3) then
sum2:=x1+x3;
writeln(sum2);
if x1 >= 0 then
SrArVsChi:=(x1+x2+x3)/3;
writeln(SrArVsChi);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?