В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Диана19371
Диана19371
01.08.2021 05:36 •  Информатика

Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них

Ответ:
abagvandmip0agkq
abagvandmip0agkq
05.10.2020 00:23
Var
  a,b,c:real;
  k:integer;
begin
  Write('Введите три числа через пробел: '); Read(a,b);
  k:=0;
  if a>0 then Inc(k);
  if b>0 then Inc(k);
  if c>0 then Inc(k);
  Writeln('Количество отрицательных чисел ',k)
end.

Пример
Введите три числа через пробел: 23.5 -24 0
Количество отрицательных чисел 1
0,0(0 оценок)
Ответ:
amersjeo
amersjeo
05.10.2020 00:23
Program zadacha;

var

a: array[1..3] of real;

i,k: integer;

begin

k:=0;

writeln('vvedite 3 chisla');

for i:=1 to 3 do read(a[i]);

for i:=1 to 3 do begin

if a[i]>0 then k:=k+1;

end;

writeln('kol-vo polojit.chisel =',k);

end.

Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?