Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
111yo11111111111
07.11.2020 10:48 •
Информатика
Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел. написать программу!
Ответ:
GorkiyShokolaD
05.10.2020 00:03
Var a,s,i:integer;
begin
s:=0;
writeln('Введите 10 чисел');
for i:=1 to 10 do
begin
read(a);
if a mod 2 = 0 then s:=s+a;
end;
writeln('s = ',s);
end.
Пример:
Введите 10 чисел
12 45 94 35 20 17 31 57 71 82
s = 208
0,0
(0 оценок)
Ответ:
MrBOPOH
05.10.2020 00:03
#include <iostream>
int main(){
int result = 0;
for (int i = 0; i < 11; i++) {
std::cin >> i;
result += ((i % 2) == 0) ? i : 0;
}
std::cout << result;
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
НикаКлубника11
22.03.2022 08:18
Решите задачи - блок-схемы и Паскаль. 1.Дано число n=25.Если удвоенное число n чем 60,то увеличить число в 7 раз, в противном случае уменьшить в 10 раз. Вывести полученное число....
Игорь2285
10.01.2021 07:17
, Напишите код на С++, желательно с комментариями Выписав первые шесть простых чисел, получим 2, 3, 5, 7, 11 и 13. Очевидно, что 6-е простое число - 13. Какое число является 10001-м...
трифон1
09.11.2021 05:43
Превратить в двоичную систему : 116, 402,215,11111, 101111,100001....
MariyamGaraeva
15.01.2021 21:21
Губарев королевство кривых зеркал от чьего лица ведется рассказ? кто рассказчик?...
бульбулядор
07.12.2020 19:19
Катеты прямоугольного треугольника равны 14 см и 48 см. определи длину медианы, проведенную к гипотенузе этого треугольника....
Alisa48329
07.12.2020 19:19
Можете написать все климатические пояса южной америки...
poulina14
07.12.2020 19:19
20 мне не жалко только правильно это к/р сhoose present continuous or present simple, write the verb form. 1. i usually (to wait for) tom. he is always late. 2. she is in the kitchen....
Pomogatorr
07.12.2020 19:19
Составьте диалог между человеком и животным, используя омонимичные части речи...
Keliris
07.12.2020 19:19
Все самое интересное про пустыню сахару!...
залина061
02.03.2021 15:24
Решить уравнение 5(а+1)-7(2а+1)= —2...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
s:=0;
writeln('Введите 10 чисел');
for i:=1 to 10 do
begin
read(a);
if a mod 2 = 0 then s:=s+a;
end;
writeln('s = ',s);
end.
Пример:
Введите 10 чисел
12 45 94 35 20 17 31 57 71 82
s = 208
int main(){
int result = 0;
for (int i = 0; i < 11; i++) {
std::cin >> i;
result += ((i % 2) == 0) ? i : 0;
}
std::cout << result;
return 0;
}