В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikailen
vikailen
25.08.2021 20:11 •  Информатика

25 в двумерном массиве хранится информация о количестве учеников в каждом классе каждой параллели школы с первой по одиннадцатую (в первом столбце — информация о классах первой параллели, во втором — второй параллели и т. в каждой параллели школы учатся 5 классов. составить программу для расчета общего числа учеников в любой параллели.

Ответ:
Bamper1
Bamper1
04.10.2020 23:33
Const
  n=5; 
  m=11;
var
  a: array[1..n,1..m] of integer;
  i,j,s: integer;
begin;
  s:=0;
  writeln ('Количество учеников по классам:');
  for i:=1 to n do begin
    for j:=1 to m do begin
      a[i,j]:=random(25,30);
      write (a[i,j]:3);
    end;
    writeln;
  end;  
  writeln;
  write ('Введите номер параллели: ');
  readln (j);
  for i:=1 to n do 
    s:=s+a[i,j];
  writeln ('В ',j,'-ой параллели всего ',s,' учеников');
end.

Результат:

Количество учеников по классам:
 27 27 28 26 28 25 27 25 27 29 26
 25 29 25 26 29 26 29 26 27 27 29
 30 25 29 27 25 28 29 27 29 26 28
 25 26 27 27 30 29 25 30 26 28 25
 28 26 28 27 28 28 25 27 28 26 30

Введите номер параллели: 5
В 5-ой параллели всего 140 учеников
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?