В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Trusters2007
Trusters2007
14.02.2022 10:39 •  Информатика

1)составьте программу на языке pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком. 2)составьте программу на языке pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения первой половины элементов увеличенных в 2 раза, а второй половины элементом уменьшенных в 2 раза.

Ответ:
ирина1844
ирина1844
09.08.2020 14:20
1)

var
mas: array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 10 do begin
if mas[i]<0 then
write(abs(mas[i]),' ')
else
write(-mas[i],' ');
end;
end.

2)

var
mas: array [1..10] of real;
i:integer;
begin
for i:=1 to 10 do
read(mas[i]);
for i:=1 to 5 do
write(mas[i]*2,' ');
for i:=6 to 10 do
write(mas[i]/2,' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?