В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gerasi1
gerasi1
17.07.2021 03:05 •  Информатика

Даны 3 числа(а,в,с). составьте программу, которая меняет местами max и min элементы.не массив.

Ответ:
вика28121
вика28121
08.09.2020 17:22
Var a,b,c,d:integer;
begin
writeln('a, b, c:');
readln(a,b,c);
if (a>b)and(a<c)or(a>c)and(a<b)
 then begin d:=b; b:=c; c:=d; end
 else if (b>a)and(b<c)or(b>c)and(b<a)
       then begin d:=a; a:=c; c:=d; end
       else begin d:=a; a:=b; b:=d; end;
writeln('a = ',a,' b = ',b,' c = ',c);
end.

Пример:
a, b, c:
8 5 2
a = 2 b = 5 c = 8
0,0(0 оценок)
Ответ:
milka230614
milka230614
08.09.2020 17:22
Var
  a,b,c:integer;
  max,min:integer;
begin
  readln(a,b,c);
  if ((a>=b)and(a>=c)and(b<=c))or((b>=a)and(b>=c)and(a<=c)) then swap(a,b)
  else
    if ((a>=b)and(a>=c)and(c<=b))or((c>=b)and(c>=a)and(a<=b)) then swap(a,c)
    else
      if ((b>=a)and(b>=c)and(c<=a))or((c>=b)and(c>=a)and(b<=a)) then swap(b,c);  writeln(a,' ',b,' ',c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?