В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
нази13
нази13
07.02.2022 12:14 •  Информатика

Составить программу, которая заполняет массив а [1..14] случайными целыми числами в диапазоне от 1 до 10, затем найти сумму элементов с чётными значениями и количество элементов с не чётными значениями

Ответ:
диана2463
диана2463
04.10.2020 22:41
Var mass:array[1..14] of integer; 
       g,s,sum:integer;
begin
randomize;
for g:=1 to 14 do
begin
mass[g]:=random(10)+1;
if (mass[g] mod 2) = 0 then begin sum:=sum+mass[g];  s:=s+1; end;
writeln(mass[g]);
end;
writeln('сумма четных = '+sum);
writeln('количество нечетных в массиве = '+(14-s));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?