В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastykatymari
nastykatymari
11.08.2020 03:20 •  Информатика

Дан массив, содержащий 20 целых чисел из промежутка [-100,100]. напишите программу,позволяющую найти и вывести наименьшее содержщееся в массиве положительное число,десятичная запись которого оканчивается цифрой 7. если таких чисел нет,укажите это

Ответ:
vytriskoivan
vytriskoivan
04.10.2020 22:34
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(20,-100,100); a.Println;
  var b:=a.Where(x->(x>0) and (x mod 10=7));
  if b.Count>0 then Writeln('Искомое число ',b.Min)
  else Writeln('Нет подходящих чисел')
end.

Пример
-5 39 27 94 -50 -3 -73 -18 -36 45 -58 47 45 69 -85 -78 -6 -99 4 -32
Искомое число 27
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?