Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
егорка140
25.10.2022 01:59 •
Информатика
1. напишите процедуру, которая выводит на экран фразу «я люблю паскаль» заданное в ее параметре количество раз. 2. напишите процедуру, которая выводит на экран решение линейного уравнения ax + b = 0. параметры а и b являются параметрами процедуры.
Ответ:
lugmar3
04.10.2020 22:13
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!
procedure Love(n:integer);
begin
Writeln(n*('Я люблю ПАСКАЛЬ'+NewLine))
end;
begin
Love(ReadInteger('n='))
end.
Пример
n= 5
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!
procedure LinEqu(a,b:real);
begin
if a=0 then
if b=0 then Writeln('Решений бесконечно много')
else Writeln('решений нет')
else Writeln('x=',-b/a)
end;
begin
var a,b:real;
Write('Введите а и b: '); Read(a,b);
LinEqu(a,b)
end.
Пример
Введите а и b: 18.45 -12
x=0.650406504065041
0,0
(0 оценок)
Популярные вопросы: Информатика
limka5180
01.05.2022 08:34
Определить информационный объём печатного издания, в котором 25 страниц, на каждоый странице 80 строк, в каждой строке 65 символов, и 2 иллюстрации, одна черно-белая размером 18x24...
nyatteloiv
01.05.2022 08:34
1. состав устройств компьютера 2. связь между аппаратными средствами 3. электронные компоненты компьютера соединены между собой группами проводников, 4. компьютеры платформы ibm pc...
ггггг21
28.08.2022 14:12
? В ответ запишите последовательность букв без занятых и других знаков препинания....
MstyanKristina
02.04.2023 04:54
1) Условный оператор if a mod 2=0 then write ( Да ) else write ( Нет ) позволяет определить, является ли число a … четным двузначным двоичным Определите значение переменной с после...
Анoнuм
18.12.2022 12:24
Перевести из 16-тиричной системы 58,23d7 в восьмиричную. подробно...
makhastiirisba
18.12.2022 12:24
Дано два простых высказывания: a = 3+3=5 и b = 5-3=4 какие из ниже высказываний истинны? 1.¬a 2.a 3.a ∧ b 4.b 5.a ∨ b 6.¬b...
малышка135
21.01.2020 22:53
(1)говядина – это мясо коровы или быка как пища. (2)рядом со словом говядина существует однокоренное прилагательное говяжий «из говядины». (3)это дает нам возможность выделить в существительном...
платон24
21.01.2020 22:53
Расстояние в 810км легковой автомобиль проезжает за 9часов, а грузовая машина - за 18часов. во сколько раз скорость дешевого автомобиля больше скорости грузовой машины?...
кристина1966
11.08.2022 01:47
Кпразднику для детского сада купили 2 ящика конфет по 11 кг в каждом и 4 ящикапряников по 10 кг в каждом...
Емодзи
11.08.2022 01:47
Текст рассуждение на тему професии (короткое 14 предложений или 20)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
procedure Love(n:integer);
begin
Writeln(n*('Я люблю ПАСКАЛЬ'+NewLine))
end;
begin
Love(ReadInteger('n='))
end.
Пример
n= 5
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
Я люблю ПАСКАЛЬ
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!
procedure LinEqu(a,b:real);
begin
if a=0 then
if b=0 then Writeln('Решений бесконечно много')
else Writeln('решений нет')
else Writeln('x=',-b/a)
end;
begin
var a,b:real;
Write('Введите а и b: '); Read(a,b);
LinEqu(a,b)
end.
Пример
Введите а и b: 18.45 -12
x=0.650406504065041