В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу, которая получает на вход строку типа "иван иванович иванов"(иоф), а выводит строку типа "иванов иван иванович"(фио)

Ответ:
Sillyteenager
Sillyteenager
29.05.2020 20:07

как то так чтоль

var f,i,o,iof:string;

c,probel:integer;

begin

readln(iof);

probel:=0;

for c:=1 to length(iof) do begin

if (iof[c]<>' ') and (probel=0) then i:=i+iof[c];

if (iof[c]<>' ') and (probel=1) then o:=o+iof[c];

if (iof[c]<>' ') and (probel=2) then f:=f+iof[c];

if iof[c]=' ' then inc(probel);

end;

writeln(f,' ',i,' ',o);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?