В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.

Ответ:
dianashotys
dianashotys
04.10.2020 22:07
Type mas=Array [1...100] of integer;
var i,n,itre:integer;
a:mas;
begin
readln(n);
for i:=1 to n
do read(A[i]);
for i:=2 to n-1
do if (A[i]>A[i-1]) and (A[i]>A[i+1])
then itre:=i;
for i:=1 to itre-2
do writeln(A[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?