В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lukash231082
lukash231082
18.12.2022 23:15 •  Информатика

Найдите ошибку плз program ideone; var a: array[1 .. 250] of integer; s,n,i: integer; begin write('please enter length of the array: '); readln(n); for i: =0 to n do begin write ('please enter an array item '); readln (a[i]); end; s: =0; for i: =1 to n do s: =s+a[i]; writeln('s=',s); end. 3 5 31

Ответ:
Avry99
Avry99
04.10.2020 21:47
Var a:array[1 .. 250] of integer;
s,n,i:integer;
begin
write('Please enter length of the array: ');
readln(n);
for i:=1 to n do
begin
write ('Please enter an array item ');
readln (a[i]);
end;
s:=0;
for i:=1 to n do
s:=s+a[i];
writeln('s=',s);
end.

Пример (в первой строке вводится количество элементов, далее - сами элементы):
Please enter length of the array: 5
Please enter an array item 3
Please enter an array item 8
Please enter an array item 2
Please enter an array item 4
Please enter an array item 6
s=23
0,0(0 оценок)
Ответ:
Prikolno2018
Prikolno2018
04.10.2020 21:47
Попробуй вместо строки 
for i:=0 to n do
Написать: for i:=1 to n do
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?