В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Wonderfulgirl30
Wonderfulgirl30
15.04.2021 04:45 •  Информатика

Написать программу на си ! : дана квадратная матрица. найти сумму четных элементов над побочной диагональю.

Ответ:
NekoChan625
NekoChan625
31.08.2020 16:24

что-то типа этого:

const n = 8, m = 8;
var 
    A: array[1..n,1..m] of integer;
    i, j, sum, product: integer;
    isnotnull: boolean;
begin
    randomize;
    writeln('Случайная матрица:');    for i:=1 to n do begin
        for j:=1 to m do begin
            A[i,j] := random(51) - 25;
            write(A[i,j]:5);
        end;
        writeln;
    end;    sum := 0;
    for i:=1 to n do
        if A[i,n-i+1] < 0 then
            sum := sum + A[i,n-i+1];
    writeln('Сумма отрицательных элементов побочной диагонали = ', sum);    product := 1;
    isnotnull := False;
    for i:=1 to n-1 do
        for j:=2 to n do
            if (j > i) and (A[i,j] <> 0) then begin
                isnotnull := True;
                product := product * A[i,j];
            end;
    if isnotnull
        writeln('Произведение ненулевых элементов в области выше главной диагонали = ', product)
    else
        writeln('Ненулевых элементов в области выше главной диагонали нет.', product);    readln;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?