В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LuKи
LuKи
29.05.2020 10:17 •  Информатика

Составьте программу вычисления в массиве а(10) заполненном случайными числами из интервала (-5,10) количества отрицательных элементов

Ответ:
maximbelov00
maximbelov00
04.10.2020 21:30
Полагаю, Pascal ABC.

//Для Pascal ABC.Net:
Var a:array[1..10] of longint;n,i,k:longint;
Begin
readln(n); //Читаем количество элементов в массиве
for i:=1 to n do
begin
read(a[i]); //Читаем каждый элемент в массиве
if (a[i]<0) then k+=1; //Увеличиваем счётчик k на 1, если элемент меньше нуля
end;
writeln(k); //Выводим счётчик k
End.

//Для Pascal ABC:
Var a:array[1..10] of integer;n,i,k:integer; //Простой Паскаль не поддерживает longint
Begin
readln(n); 
for i:=1 to n do
begin
read(a[i]); 
if (a[i]<0) then k:=k+1; //Отличие в том, что здесь нельзя просто увеличить с только с :=k+1
end;
writeln(k); //Выводим счётчик k
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?