Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
irinasid
12.12.2020 20:51 •
Информатика
Составить программу в паскале,! составить программу вычисления максимального значения функции y=x^2-3x+lnx при изменении аргумента x в интервале 1< =x< =5 с шагом 0.5
Ответ:
alexaaa2
04.10.2020 21:08
1. Современный вариант
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Print(Range(1.0,5.0,Floor((5-1)/0.5)).Select(x->x*x-3*x+ln(x)).Max)
end.
Результат
11.6094379124341
2. Школьный вариант (ну вот так у нас в школах учат!)
var
x,y,max:real;
begin
max:=-1000;
x:=1;
while x<=5 do
begin
y:=sqr(x)-3*x+ln(x);
if max<y then max:=y;
x:=x+0.5
end;
Write(max)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
снегурочка01
16.08.2020 12:43
Что такое дисплейный процессор и какую работу он выполняет...
polinasmi1
05.05.2023 03:46
Як скопіювати файл, використовуючи буфер обміну?...
FvitalikA
29.05.2021 11:50
Сколько времени потребуется сети работающей со скоростью 56000 бит/с для передачи 30 страниц текста по 50 строк в 70 символов каждая, при условии что каждый символ кодируется...
ul8a
29.05.2021 11:50
Алгоритмы паскаль (массив) 15 б сформулировать и вывести на экран такой массив: (5 10 15 20 25 30 35 40 45 50 55 60 65 70 75 80 85 90)...
Hactenьka
25.05.2022 23:34
Информационное сообщение объемов 2,5 кбпйта передается со скоростью 2560 бит/мин . за сколько минут будет передано данное сообщение...
AlexCairon5
21.01.2021 02:41
Память компа устройство и назначение...
Ритка069
04.08.2021 12:02
Яка нічна тварина спить обгорнувши голову хвостом...
Полина9111111
08.06.2021 23:36
1) как называется строка, содержащая информацию о текущем состоянии окна? 2)как называется область, содержащая вложенные папки или окна документов? 3) как называется панель...
tamirisis7sk
16.11.2021 01:09
Вычислите ! информатиа 8 класс 2 кбайта = бит. подробно с вычислениями...
edigarian2016
14.11.2021 18:43
Основные характеристики устройств внешней памяти...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.2, сборка 1359 от 11.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
Print(Range(1.0,5.0,Floor((5-1)/0.5)).Select(x->x*x-3*x+ln(x)).Max)
end.
Результат
11.6094379124341
2. Школьный вариант (ну вот так у нас в школах учат!)
var
x,y,max:real;
begin
max:=-1000;
x:=1;
while x<=5 do
begin
y:=sqr(x)-3*x+ln(x);
if max<y then max:=y;
x:=x+0.5
end;
Write(max)
end.