В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dimon22872
Dimon22872
10.09.2022 08:46 •  Информатика

Составьте программу, которая позволяет заменить в строке слово мама на слово папа

Ответ:
ррпарпоа1
ррпарпоа1
02.08.2020 16:53
Var //Объявляем переменные
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s);  // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
 begin  
Delete(s, i, 4);  // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа 
Insert('папа', s, i);  // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?