Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
alisaislamova2
15.01.2021 15:25 •
Информатика
Pascalabc нужно составить программу для вывода ближайшего степени 2-ки
Ответ:
DanyaHD
08.09.2020 14:50
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadInteger('Введите натуральное число:');
var p:=Round(log2(s));
Writeln('Два в степени ',p,' = ',power(2,p))
end.
Пример
Введите натуральное число: 4093532
Два в степени 22 = 4194304
0,0
(0 оценок)
Популярные вопросы: Информатика
Sark23
27.08.2021 05:21
В коком году программу купила корпорация...
anelya41
22.03.2021 09:51
Жай баспа мен 3Dбаспаны салыстырындар. Уксастыктары мен айырмашылыктарын айтындар информатика...
varvara124
12.06.2020 22:46
Решить ! ) с клавиатуры вводится строка произвольной длины строка содержит только маленькие буквы вывести на экран строку в которой маленькие буквы будут преобразованы...
228665123
19.10.2021 09:51
(visual studio c# нужно сделать проверку значений a. т.к. в коде a имеет значение double, нужно выдавать сообщение если пользователь ввел не имеющий формат double,...
elena2213
07.04.2021 11:33
Написать программу на языке паскаля авс ***дана матрица. сформировать одномерный массив, элементами которого являются суммы тех строк, которые начинаются с k идущих...
ника3931
20.09.2021 01:56
Определите тип ориентации текстового документа...
anmon07
18.02.2020 04:05
4. укажите количество ячеек, в адресах которых не допускается изменение только имени строки: 1.e$1 3.$r$21 5.q23 7.$as1 9.g4 2.$a1 4.a$45 6.as$12 8.er45 10.$g$1...
pervushin752
06.02.2020 14:00
Напечатать таблицу перевода температуры из градусов по шкале цельсия (с) в градусы шкалы фаренгейта (f) для значений от 15ос до 30ос с шагом 1ос. (перевод осуществляется...
АннаМокеева
21.01.2022 01:48
Заполнить массив из 50 случайных чисел подсчитать сумму элементов массива и вывести результат на экран...
teenwolf18
13.06.2021 06:14
Впрограмме используется одномерный целочисленный массив a с индексами от 0 до 9. значения элементов равны 7; 3; 4; 8; 6; 9; 5; 2; 0; 1 соответственно, т.е. a[0]=7;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadInteger('Введите натуральное число:');
var p:=Round(log2(s));
Writeln('Два в степени ',p,' = ',power(2,p))
end.
Пример
Введите натуральное число: 4093532
Два в степени 22 = 4194304