Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lizatim2005
07.08.2020 16:39 •
Информатика
Составить программу, которая обеспечит ввод 15 чисел и определит сколько из них отрицательных, которые кратны 3.
Ответ:
sergeicyupka
04.10.2020 19:44
Var a,i,k:integer;
begin
k:=0;
writeln('Введите 15 целых чисел:');
for i:=1 to 15 do
begin
readln(a);
if (a<0)and(a mod 3 = 0) then k:=k+1;
end;
writeln('k = ',k);
end.
Пример:
Введите 15 целых чисел:
75
-65
15
-68
28
-42
80
-76
51
-32
18
-16
-45
70
-65
k = 2
0,0
(0 оценок)
Популярные вопросы: Информатика
vasakaktakovlwla
29.10.2021 04:24
Разведчик выяснил, что ключ к замку от сейфа состоит из трёх символов, причём могут использоваться буквы из алфавита {а, в, с, d}. две одинаковые буквы не могут стоять...
muralova
16.02.2022 01:25
вас быстрее.перенести выражение в pascal...
jannamkrtchyan
04.01.2021 22:56
Калькулятор работающий в троичной системе счисления, имеет пять знакомест для вывода числа на экран. с каким самым большим десятичным числом можно работать на этом калькуляторе...
ruslanantosyuk1
04.01.2021 22:56
Укажите номера чисел по возрастанию: 11(10) десятичный эквивалент номер возрастания 101(8) 110110(2)...
silwana2002
04.01.2021 22:56
C#, консоль дана строка s. разделить строку на отдельные слова не используя стандартные средства для разбиения строк...
fd1132
12.10.2020 08:50
Необходимо нарисовать 38 одинаковых вертикальных палочек. Дан алгоритм. Выбери верный ответ.использовать Чертежникалг черточки11начсместиться в точку (-4,3)нц разопустить...
Ruslanchik111
22.02.2023 06:11
Логическое отрицание. таблица истинности. (ок1, ок4, ок8, ок9)...
dashalarkina131
22.02.2023 06:11
Дана строка символов , груп символов разделенные пробелом (одним или несколькими )и не содержащие пробелолов внутри себя , будем называть словами . слова читающиеся с...
pomogitmneaaaa
22.02.2023 06:11
Опишите связи между таблицами с множественностью и полнотой. опишите алгоритм нахождения в базе данных данных по определенным критериям отбора, создавая простые запросы...
Toto112
22.02.2023 06:11
1. принципы кодирования информации в восьмеричной системе счисления. примеры. 2. текстовые редакторы, настольные издательские системы и их возможности, предоставляемые...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
k:=0;
writeln('Введите 15 целых чисел:');
for i:=1 to 15 do
begin
readln(a);
if (a<0)and(a mod 3 = 0) then k:=k+1;
end;
writeln('k = ',k);
end.
Пример:
Введите 15 целых чисел:
75
-65
15
-68
28
-42
80
-76
51
-32
18
-16
-45
70
-65
k = 2