В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Yulyaisaeva2005
Yulyaisaeva2005
04.04.2021 18:43 •  Информатика

Составьте программу вычисления функции y=sinx2^n используйте подпрограмму,функцию для ее вычисления

Ответ:
sergnovop08ly5
sergnovop08ly5
04.10.2020 19:14
Var x,y:real; n:integer;
function f(x:real;n:integer):real;
var i,st:integer;
begin
st:=1;
for i:=1 to n do st:=st*2;
f:=sin(x)*st;
end;
begin
writeln('x, n:');
readln(x,n);
y:=f(x,n);
writeln('x = ',x,' y = ',y);
end.

Пример:
x, n:
2 5
x = 2 y = 29.0975176584218
0,0(0 оценок)
Ответ:
4ev43yi3
4ev43yi3
04.10.2020 19:14
Program sinus;
var x,y:real;
begin
writeln('введите число');
readln(x);
y:=sin(x)*2*2;
writeln(y);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?