В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Доминат
Доминат
24.12.2021 17:55 •  Информатика

Турбо паскаль! факториалом числа m называется произведение натуральных чисел от 1 до m. m! =1*2*3*..*m; 4! =1*2*3*4=24. требуется написать программу, которая подсчитывает количество факториалов между n и k(включительно). формат входа данных: на вход подается два натуральных числа n и k, записанные через пробел. (1

Ответ:
lisi3
lisi3
04.10.2020 18:10
Var n,k,fact:int64;
c,i:longint;
Begin
readln(n,k);
fact:=1;
i:=2;c:=0;
while(fact<=k) do
Begin
if (fact>=n)and(fact<=k) then inc(c);
fact:=fact*i;
inc(i);
end;
writeln(c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?