В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Mako9375
Mako9375
30.06.2022 22:46 •  Информатика

Информатика. составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 0 до 10 и находит сумму минимального и максимального элементов массива

Ответ:
katytucan1
katytucan1
04.10.2020 18:08
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,0,10); a.Println;
  Writeln(a.Max+a.Min)
end.

Пример
6 5 4 7 5 8 8 10 0 2
10
0,0(0 оценок)
Ответ:
EdSid
EdSid
04.10.2020 18:08
Си.

#include <stdio.h>
#include <stdlib.h>

void main( void )
{
   int A[10], max = A[0], min = A[0], i;

  for (i = 0; i < 10; i++)
  {
    A[i] = rand() / RAND_MAX * 10;
    if (A[i] < min)
      min = A[i];
    if (A[i] > max)
      max = A[i];
  } 
}

printf("Sum of min & max: %i", (max + min));
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?