В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Katialka11
Katialka11
29.01.2023 21:45 •  Информатика

Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.

Ответ:
Маркіза1
Маркіза1
14.08.2020 13:55
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>').ToWords.JoinIntoString;
  s.Println;
end.

Пример
>     А   роза   упала на     лапу    Азора
А роза упала на лапу Азора
0,0(0 оценок)
Ответ:
lesanazyrova
lesanazyrova
14.08.2020 13:55
Uses System;
uses System.Linq;var s: array of string;
a: string;
i, x: integer;begin
readln(a);
s := a.Split();
for i := 0 to s.Length - 1 do
  if (s[i].Length <> 0) then
    write(s[i] + ' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?