В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
hdblin530
hdblin530
31.12.2021 04:31 •  Информатика

(pascal)составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа

Ответ:
Chuiruss
Chuiruss
04.10.2020 17:49
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('->');
  var c:=s[1];
  for var i:=2 to s.Length do
    if s[i]=c then begin Writeln(c,' - повторяющийся символ'); exit end
    else c:=s[i];
  Writeln('Повторяющихся символов нет')
end.

Пример
-> переезд
е - повторяющийся символ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?