В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alisa332
alisa332
28.02.2021 06:41 •  Информатика

Составить программу, которая определяет встречаются ли в значении строковой величины два подряд идущих одинаковых символа

Ответ:
grgrgrgrgrrhrrhrgrgr
grgrgrgrgrrhrrhrgrgr
02.08.2020 15:24
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication4
{
    class Program
    {
        static void Main(string[] args)
        {
            bool result = false;
            Console.WriteLine("Введи строку");
            string str = Console.ReadLine();
            for (int i = 0; i < str.Length - 1; i++)
            {
                if (str.Substring(i, 1) == str.Substring(i + 1, 1))
                {
                    result = true;
                    break;
                }
            }

            if (result == true)
                Console.WriteLine("Да, встречаются");
            else
                Console.WriteLine("Нет, не встречаются");

            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?