В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
GrafGundam
GrafGundam
18.05.2020 07:36 •  Информатика

Напишите программу на языке паскаль, которая будет вычислять наибольший общий делитель для двух целых чисел а) с repeat б) с while

Ответ:
djiner
djiner
29.05.2020 16:59

а)

var a,b:integer;

begin

read(a,b);

repeat

if a>b then

a:=a-b

else

b:=b-a;

until (a=b);

write(a);

end.

б)

var a,b:integer;

begin

read(a,b);

while (a<>b) do

if a>b then

a:=a-b

else

b:=b-a;

write(a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?