В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
чинка2
чинка2
12.10.2021 01:27 •  Информатика

2) заполнить массив а случайными целыми числами разных знаков. составить программу вывода на экран номеров элементов массива, равных максимальному.

Ответ:
gritana
gritana
04.10.2020 17:41
Var mas: array[-1000..1000] of integer;
  i, max, n: integer;
begin
  {ввод количества элементов массива}
  readln(n);
  {ввод массива и его вывод на экран}
  randomize;
  for i := 1 to n do 
  begin
    mas[i] := 50 - random(100) - 1;
    write(mas[i]:5);
    if (i mod 10 = 0) then writeln;
  end;
  {поиск максимума}
  max := mas[1];
  for i := 2 to n do  
    if (mas[i] > max) then max := mas[i];
  {нахождение номеров элементов массива}
 writeln;
  for i:=1 to n do if (mas[i] = max) then write(i,'  ');
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?