В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
namik147258369
namik147258369
21.01.2022 14:42 •  Информатика

1) напишите программу в паскале заполнить массив случайными целыми числами. заменить элементы массива, кратные k нулями, остальные 1 ( к ввести с клавиатуры)

Ответ:
Danielriisna13
Danielriisna13
04.10.2020 17:40
var
  mas: array[-1000..1000] of integer;
  i, k, n: integer;

begin
  {ввод количества элементов массива}
  readln(n);
  {ввод числа к}
  readln(k);
  {ввод массива и его вывод на экран}
  randomize;
  for i := 1 to n do 
  begin
    mas[i] := 50 - random(100) - 1;
    write(mas[i]:4);
    if (i mod 10 = 0) then writeln;
  end;
  {замена элементов массива}
 writeln;
  for i:=1 to n do begin
  if (mas[i] mod k=0) then mas[i]:=0
  else
  mas[i]:=1;
  write (mas[i]:4);
  if (i mod 10 = 0) then writeln;
  end;
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?