В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sania24sania
Sania24sania
03.06.2020 22:19 •  Информатика

Напишите программу, которая для последовательности натуральных чисел находит среднее арифметическое. программа получает на вход числа, кол-во чисел неизвестно, последовательность заканчивается числом 0 (0 в последовательность не входит)

Ответ:
mdasa7375
mdasa7375
04.10.2020 17:09
Var
  a: array[1..1000] of integer;
  sa: real;
  i: byte;
begin
  writeln ('Введите числа: ');
  i:=0;
  sa:=0;
  repeat
    i:=i+1;
    read (a[i]);
    sa:=sa+a[i];
  until a[i]=0;
  sa:=sa/(i-1);
  writeln ('Среднее арифметическое чисел = ',sa);
end.

Пример:
Введите числа: 
2 4 2 4 2 4 0 
Среднее арифметическое чисел = 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?