В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
7Dancho
7Dancho
28.04.2020 08:27 •  Информатика

)) составьте программу вычисления суммы элементов четных строк массива т (6,5) и произведения элементов нечетных строк.

Ответ:
Karaokpiao
Karaokpiao
04.10.2020 16:52
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrRandom(6,5,-50,50); a.Println(4); Writeln;
  var res:=new int64[6];
  for var i:=0 to 5 do
    if i.IsEven then
      res[i]:=a.Row(i).Aggregate(int64(1),(x,y)->x*y)
    else
      res[i]:=a.Row(i).Sum;
  Writeln('Результаты:'); res.Println(NewLine)
end.

Пример
 -32  22  12   8 -38
  45  22 -12  26  -2
 -46  12  19  42  -1
  19   5  29 -41 -41
  10 -23   2 -19  10
  -4  22  15  34  34

Результаты:
2568192
79
440496
-29
87400
101
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?