В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
максим1723
максим1723
08.08.2022 16:44 •  Информатика

Заданы длины катетов прямоугольного треугольника. составьте программу,с которой определите радиус вписанной и радиус описанной окружности.

Ответ:
DeniSNok
DeniSNok
04.10.2020 16:58
Формулы:
с=кв.корень из (а^2+b^2)
r=(a+b-c)/2
R=c/2

var   a,b,c,r1,r2: real;
begin
  write ('введите катет а: ');
  readln (a);
  write ('введите катет b: ');
  readln (b);
  c:=sqrt(a*a+b*b);
  r1:=(a+b-c)/2; //радиус вписанной окружности
  r2:=c/2; //радиус описанной окружности
  writeln;
  writeln ('r = ',r1:6:2);
  writeln ('R = ',r2:6:2);
end.

Пример:
введите катет а: 4
введите катет b: 6
r =   1.39
R =   3.61
***значения округлены до 2 знаков после запятой
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?